当前位置: 代码网 > it编程>数据库>Mysql > CentOS8 Mysql启动失败问题及解决过程

CentOS8 Mysql启动失败问题及解决过程

2026年09月30日 • Mysql •我要评论
1. 问题描述启动mysql失败[root@primo ~]# service mysqld startstarting mysqld (via systemctl): job for mysqld

1. 问题描述

启动mysql失败

[root@primo ~]# service mysqld start
starting mysqld (via systemctl):  job for mysqld.service failed because the control process exited with error code.
see "systemctl status mysqld.service" and "journalctl -xe" for details.
[failed]

2. 原因分析

查看mysql日志

can't start server: can't check pid filepath: no such file or directory

原来时mysql启动时没找到pid filepath,通过命令cd /var/run/进入文件夹,发现没有mysqld文件夹,导致启动失败

3. 解决办法

1. 新建mysqld 文件夹

[root@primo run]# mkdir /var/run/mysqld/

2. 修改操作权限

[root@primo run]# chown mysql.mysql /var/run/mysqld/

3. 重启mysql,此时可以正常启动了

[root@primo run]# service mysqld start
starting mysqld (via systemctl):  [  ok  ]

4. 总结

以上为个人经验,希望能给大家一个参考,也希望大家多多支持代码网。

赞 (0)

相关文章:

版权声明:本文内容由互联网用户贡献,该文观点仅代表作者本人。本站仅提供信息存储服务,不拥有所有权,不承担相关法律责任。 如发现本站有涉嫌抄袭侵权/违法违规的内容, 请发送邮件至 2386932994@qq.com 举报,一经查实将立刻删除。

发表评论

验证码:
Copyright © 2017-2026  代码网 保留所有权利. 粤ICP备2024248653号
站长QQ:2386932994 | 联系邮箱:2386932994@qq.com