1. 问题描述
启动mysql失败
[root@primo ~]# service mysqld start starting mysqld (via systemctl): job for mysqld.service failed because the control process exited with error code. see "systemctl status mysqld.service" and "journalctl -xe" for details. [failed]
2. 原因分析
查看mysql日志
can't start server: can't check pid filepath: no such file or directory
原来时mysql启动时没找到pid filepath,通过命令cd /var/run/进入文件夹,发现没有mysqld文件夹,导致启动失败
3. 解决办法
1. 新建mysqld 文件夹
[root@primo run]# mkdir /var/run/mysqld/
2. 修改操作权限
[root@primo run]# chown mysql.mysql /var/run/mysqld/
3. 重启mysql,此时可以正常启动了
[root@primo run]# service mysqld start starting mysqld (via systemctl): [ ok ]
4. 总结
以上为个人经验,希望能给大家一个参考,也希望大家多多支持代码网。
发表评论